FANDOM


Das Erstellen einer eigenen Anweisung erfolgt durch die Benutzung der standardmäßig verfügbaren Bedingungen/Anweisungen. Dazu anzumerken ist, dass Bedingungen nur im Zusammenhang mit Kontrollstrukturen wie wenn oder solange benutzt werden können.

Schreibweise Bearbeiten

Das Erstellen einer Anweisung ist immer gleich aufgebaut:

 Anweisung Benutzerdefinierter Anweisungsname
%Anweisungen/Bedingungen mit Tabulator davor%
*Anweisung

Beispiel:

Anweisung LegenMitAusgangsposition
Schritt
LinksDrehen
LinksDrehen
Hinlegen
Schritt
LinksDrehen
Linksdrehen
*Anweisung

~Karol geht auf das nächste Feld, legt auf das erste einen Ziegel und läuft darauf